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        <title>Knowledge Base knowledge-base:database-migration:setup-and-troubleshooting:progress</title>
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       <dc:date>2026-06-26T20:54:57+0000</dc:date>
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        <dc:date>2023-12-15T09:56:15+0000</dc:date>
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        <title>Lock Table is Full (7870)</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/error-7870?rev=1702634175&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
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Lock Table is Full (7870)

Symptoms

When exporting data from the Progress database the “Lock table is full (7870)” error is returned.

Cause

By default, the PROGRESS ODBC uses READ COMMITTED isolation level that forces the row level locking for the connection. That means that for each record that you are working with in the database within one transaction the Lock Table is updated. As Lock Table is limited in number of rows t…</description>
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        <dc:date>2023-12-15T10:01:50+0000</dc:date>
        <dc:creator>Anonymous (anonymous@undisclosed.example.com)</dc:creator>
        <title>Column Origin in Table has Value Exceeding its Max Length or Precision</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/error-column-value?rev=1702634510&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
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Column Origin in Table has Value Exceeding its Max Length or Precision

Problem

The problem arises when you try to export the data, that is longer than the SQL-WIDTH specified for the column, using the ODBC connection.

Solution

Manual Solution</description>
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        <dc:date>2023-12-15T10:03:26+0000</dc:date>
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        <title>[OpenLink][ODBC][Progress Server]** Unable to Understand After -- &quot;DECLARE&quot;</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/error-declare?rev=1702634606&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
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[OpenLink][ODBC][Progress Server]** Unable to Understand After -- &quot;DECLARE&quot;

Symptoms

 When connecting to Progress database through the OpenLink driver using Ispirer Toolkit there is an error [OpenLink][ODBC][Progress Server]* * Unable to understand after</description>
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        <dc:date>2023-12-15T10:03:48+0000</dc:date>
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        <title>Starting Database Using Progress Explorer Tool</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/explorer-tool?rev=1702634628&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
Free Trial

Starting Database Using Progress Explorer Tool

Before you can connect to Progress database you need to ensure that the database is connected to the server either local or remote. And if the database is not connected to server, you can attach it to the server and start to be able to connect to it using the ODBC driver. You can do this using the</description>
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        <dc:date>2023-12-15T10:07:18+0000</dc:date>
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        <title>Driver Configuration Advanced Tab</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/odbc-driver-configuration-advanced?rev=1702634838&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
Free Trial

Driver Configuration Advanced Tab



Default Isolation Level

 Here you can specify the default isolation level for the concurrent transactions.

READ COMMITTED

 A share lock is acquired on the record that is read. The duration of the lock varies.
The uncommitted modified records can't be read. However, if a record is read
multiple times in the same transaction, the state of the record can be different each
time.</description>
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        <dc:date>2025-04-23T14:43:02+0000</dc:date>
        <dc:creator>Anonymous (anonymous@undisclosed.example.com)</dc:creator>
        <title>Progress: ODBC Driver Configuration</title>
        <link>https://support.ispirer.com/knowledge-base/database-migration/setup-and-troubleshooting/progress/odbc-driver-configuration?rev=1745419382&amp;do=diff</link>
        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
Free Trial

Progress: ODBC Driver Configuration

In order to connect to the Progress database through ODBC, it should be connected to your server.

Learn how to connect your database to the server. To set up an ODBC connection you need to install the ODBC driver that is included in the installation package of Progress OpenEdge.</description>
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        <dc:date>2023-12-15T10:05:24+0000</dc:date>
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        <title>Progress: ODBC Driver Installation</title>
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        <description>Ispirer Website
Ispirer Capabilities: Progress Migration
Free Trial

Progress: ODBC Driver Installation

	*  Before install the Progress OpenEdge ODBC please install the JDK to the PC if necessary and set correct JavaHome directory in the oedk_response.ini file:
  [Select JavaHome Dialog]
  JavaHome=C:\Program Files\Java\jdk-19</description>
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